Back to forum
image
rss 211 weeks ago
I ordered a shirt 2 days ago, and I go to the tracking and my shipping address secondary line has a "$" sign in front of it. Is that a bad thing? Or did I make a typo...
9Comments
  • image
    211 weeks ago
    The best place to ask this question is to email [email protected] - they can take a look and let you know if there's a problem.
  • image
    211 weeks ago
    mine had the same thing the first time i ordered. Made it to my apt just fine (and with no $ in the label).
  • image
    211 weeks ago
    kayper said: mine had the same thing the first time i ordered. Made it to my apt just fine (and with no $ in the label).


    great! thank you very much!
  • image
    211 weeks ago
    BeetsAndBears said:
    kayper said: mine had the same thing the first time i ordered. Made it to my apt just fine (and with no $ in the label).



    great! thank you very much!


    Not a problem! Next time you order, be sure to check your shipping address as mine showed my city for the secondary line with no apt # mentioned. Not sure why that is, but just keep a look out for it and make sure to double check before you click "confirm".
  • image
    211 weeks ago
    There must be a couple of bugs in the address system, with all my details entered correctly into the right fields, the 'A' in the initials of state I am in prints twice. (WAA- should be WA) -Western Australia.

    I notified Tom at service@teefury he said the tech would look at it, it's not been fixed yet, but the shirts still get here no worries. :)
  • image
    211 weeks ago
    What is the average time for an order to be processed anyways?
  • image
    211 weeks ago
    I placed an order on the 15th and it shipped on the 26th
  • image
    211 weeks ago
    I just made and ate a cheeseburger.
  • image
    211 weeks ago
    melbel said: I placed an order on the 15th and it shipped on the 26th


    awww i guess it's time to wait


Back to Top